NOT helpful at all. MTS is terrible signal service and we are strongly considering switching to shaw

  • 1
  • Problem
  • Updated 2 years ago
  • Acknowledged
  • (Edited)
i just got off the phone with talking to the tech support with MTS and spoke to a Krista or Crystal she wasn't even clear with her name, told her about the EXTREMELY slow service signal we are receiving and she was NOT helpful at all. She was blunt cold and no help what so ever. made me do a speed test said everything was working that its my issue or i should upgrade my service... Right now the service I'm getting with MTS is terrible, weak, and the support IS NOT HELPFUL and don't care and we are strongly considering changing to shaw...
Photo of sc


  • 70 Points

Posted 2 years ago

  • 1
Photo of Clifford Lewis

Clifford Lewis, Champion

  • 26,966 Points 20k badge 2x thumb
I guess I have a few questions:

what do the speed tests show.  I usually suggest using the  as it gives a fair response to a server in Winnipeg as opposed to a site hosted out of Manitoba.

have you power cycled your modem or main MTS  box where the signal comes in the house and have you rebooted your PC?   (rebooting the MTS modem or main TV box  and / or the PC at times can clean up connection problems when they reconnect to the network)

Have you run a virus scan  -  some of the virus can run in the background and slow down your sessions.
Photo of turtlepower


  • 1,066 Points 1k badge 2x thumb
What service do you have, and what speeds are you getting on the speed test?
Photo of Tennille

Tennille, Social Media Coordinator

  • 15,524 Points 10k badge 2x thumb
Hello SC, 

I'm sorry to hear that you didn't receive the help you needed when you spoke to technical support. I'd like to look into this for you as this isn't the experience we want you to have, if you can send your account number and contact information to we will gladly investigate what happened and provide you with a callback regarding your services. 

Thank you, 
Photo of CoryB

CoryB, Champion

  • 27,362 Points 20k badge 2x thumb
I think two things are at play based on the original posts.

1. The service SC is having issues with is high speed home service based on the talk of changing to Shaw.
2. The issue is limited/weak WiFi coverage from the gateway.

This is covered in great detail over on the Dropped Wifi Thread with Jesse posting an excellent link of WiFi interference.

Issues with WiFi are sadly becoming increasingly common on here and are outside the scope of the service MTS can provide as the space is heavily unregulated and constantly in flux.

Here is the link to the other thread: