My high speed internet is only.65 tonight.

  • 1
  • Question
  • Updated 2 years ago
  • Answered
Photo of Ken Mansell

Ken Mansell

  • 328 Points 250 badge 2x thumb
  • ripped off by MTS,hope the new owner is better than MTS

Posted 2 years ago

  • 1
Photo of Amanda

Amanda, Alum

  • 3,976 Points 3k badge 2x thumb
Hi Ken, sorry to hear you were having speed issues last night.  If you would like to contact the help team to troubleshoot the problem visit for the method you prefer to interact with us.  Or you can provide a more info here and the community members can try and assist! 

Thanks, Amanda
Photo of CoryB

CoryB, Champion

  • 27,342 Points 20k badge 2x thumb

A good tip to try when you run into speed issues is to try resetting your hardware by unplugging the power source.

1. Power off all wireless devices such as tablets and cell phones.

2. Power off all computers.

3. Unplug any customer owned network gear such as routers, extenders, etc.

4. Unplug all MTS tv boxes.

5. Unplug the MTS gateway.

6. Wait two minutes.

7. Plug the MTS gateway back in and wait until the lights settle into the all green pattern.

8. Plug in a single computer connected directly to the MTS gateway by a network cable.

9. Test your speed, if it is better you have potentially resolved the issue.

10. Plug the MTS PVR box back in. If you got the correct one once it boots you will be able to see recorded programming.

11. Retest speeds.

12. Plug in remaining MTS tv boxes one at a time and retest speed after each one.

13 . Plug in customer owned network gear one device at a time and retest after each one.

14. Turn back on remaining computers one at a time, retesting after each one.

15. Bring the wireless devices back on one at a time, retesting after each one.

If you fully follow these steps and retest the speed only from the computer used in step 8 you will have identified which device is causing the speed issues. If you have a speed issue starting at step 8 there is a good possibility it is an MTS side issue however it could still be that one computer that has the issue.