My account app

  • 1
  • Problem
  • Updated 1 year ago
  • Solved
For about 2 weeks when I try too look into how much data I am using I get a message saying invalid MDN provided can some one please see why and fix it I only have a 3gb plan and don't want to go over thanks.
Photo of mcmanone

mcmanone, Champion

  • 6,700 Points 5k badge 2x thumb

Posted 1 year ago

  • 1
Photo of Clifford Lewis

Clifford Lewis, Champion

  • 27,078 Points 20k badge 2x thumb
Works for me but I have unlimited data. 

Have you tried to delete the app and reinstall it?  I wonder if something has gotten corrupt on your phone and that's why its not working properly.

If that does not work then its fairly certain that the problem is with MTS backend.  I am going to take a wild guess that MDN stands for Mobile Device Number?
(Edited)
Photo of mcmanone

mcmanone, Champion

  • 6,700 Points 5k badge 2x thumb
I think it's because I got a new number 2 weeks ago but they didn't set something up right.
Photo of Clifford Lewis

Clifford Lewis, Champion

  • 27,078 Points 20k badge 2x thumb
Probably quickest to go thru chat and see if support can fix it that way
Photo of mcmanone

mcmanone, Champion

  • 6,700 Points 5k badge 2x thumb
Called then this morning they had no idea told me too call billing will next week.
Photo of mcmanone

mcmanone, Champion

  • 6,700 Points 5k badge 2x thumb
This is crazy called support they say call billing call billing they say call support :(
Photo of Jeremy

Jeremy, Official Rep

  • 18,704 Points 10k badge 2x thumb
Hey mcmanone,
A couple things that you could try, re-install the app, as this could be needed after the phone number change.  You can also go into the phone settings and make sure your new number is listed there.  As for the MTS side, we would have to ensure that your account was all updated correctly and your new phone number is listed correctly under your original account number.  If the account number changed then it could cause this issue.  So I can see why you would need to speak to both departments as multiple things need to be checked.  I hope these ideas help point you in the right direction.
Photo of mcmanone

mcmanone, Champion

  • 6,700 Points 5k badge 2x thumb
Tried unstall a few times no luck I send u a email at community with account number something is worng under my phone the number is there.
Photo of Tennille

Tennille, Social Media Coordinator

  • 15,524 Points 10k badge 2x thumb
Good morning, mcmanone! 

Looks like Advanced technical support was able to help you with the issue using the steps they provided.   I'm going to share the steps below for anyone else that might be having the same issue: 

Log into to the MyAccount app
Look at the upper left corner of the screen (next to Summary) there are the three lines (the Menu) 
Press that you will see a list of Menu options
The third down from Summary, is a phone number with a smartphone icon
If that is the old number (or even the new number), press that and you will get a new screen where you can select your new number. 
Press 'Ok'

By default the MyAccount app will try and load the last number you were viewing details for.
If it still errors out, contact us via any of our Technical Support contact points: https://www3.mts.ca/mts/contact+us