MTS rejecting email

  • 3
  • Problem
  • Updated 3 years ago
  • Not a Problem
My organization sends opt-in emails to people all across Canada, but MTS is rejecting our messages.  I am trying to determine why they are rejected and how I can resolve this issue for our contacts that use MTS.

The error message is:
This message was created automatically by the mail system (ecelerity).

 A message that you sent could not be delivered to one or more of its recipients. This is a permanent error. The following address(es) failed:

 >>> XXXX@mts.net (reading confirmation): 554 5.7.1 [P4] Message blocked due to spam content in the message.


Photo of Ken

Ken

  • 90 Points 75 badge 2x thumb

Posted 3 years ago

  • 3
Photo of Jeremy

Jeremy, Official Rep

  • 18,704 Points 10k badge 2x thumb
Official Response
Hi Ken,
That error message you are quoting sounds like the emails are being flagged by the spam filter and getting blocked directly by the server.  Currently we use Microsoft as our email service provider and I have seen this issue in the past where they will block emails from a domain that has certain content.  I found a post on the Microsoft support site that may be helpful for you and can be found here.  Jason is 100% correct in saying you can contact our support team and they can look into it further, however just from my experience in seeing issues like this in the past the end result may be that you need to contact Microsoft directly to have your domain white listed.  With this all being said, if it is only certain recipients that are generating this bounce back where others at the same domain work then it's a completely different issue and would have to be addressed on a case by case basis.  The above situation you indicated sounded like all @mts.net email address' are generating bounce backs which is why I gave my initial suggestion.