iPhone 4S Battery Issue

  • 1
  • Problem
  • Updated 3 years ago
  • Acknowledged
I have a iPhone 4s with ios 7.1.2 My wife has a iPhone 4s with ios 5.1.1 We live in Tyndall, Mb and have little to no phone reception. I installed a Wilson whole house booster and the reception improved 100%. Problem is battery life on my phone is about 8 hours if I'm lucky. My wife's phone will last 2 days. We are not heavy users. When we go to our cottage at Falcon Lake, both phones last the same amount of time, which is at least 2 days. Why is it that my phone will not last in Tyndall, but it will in Falcon Lake and there is no change in the amount of time my wifes phone lasts?  Both phones are on Wi-Fi at home and the cottage.
Photo of Larry S

Larry S

  • 70 Points

Posted 3 years ago

  • 1
Photo of Justin


  • 3,598 Points 3k badge 2x thumb
Just as a regular customer, Could be the signal of the phone is trying to find itself more when you're at home - the tower may not be that great at home compared to say at Falcon Lake.
Photo of David B

David B

  • 290 Points 250 badge 2x thumb
I'm thinking something along the lines of what Justin said. That it's searching for a signal (either cell or wifi) and that's causing it to drain faster.

There's some tips on iOS 7 and battery savings here (if you haven't already tried them):


Many of them were new to iOS 7 - so that might be why your wife's phone is OK on 5. In particular, I'd try the ones related to location services.
Photo of Cecile

Cecile, Official Rep

  • 870 Points 500 badge 2x thumb
 Both Justin and David are correct.  I don't know your exact location in the Falcon Lake area, but since you are using a booster at home, that's a clear indication that the coverage in Tyndall is not comparable to Falcon Lake.  David provided an awesome link on how to adjust or check your settings as there are reported known issues with the iOS7 causing the battery to drain faster. Another suggestion would be to turn data off while you are at home in Tyndall so your phone is only utilizing wifi. Hope that helps!