Budweiser Red Light Connection Problems

  • 2
  • Problem
  • Updated 8 months ago
We recently upgraded our home network to dual band 2.4/5 GHz, and since then I’ve been unable to connect my light. I’ve been only trying to connect to the 2.4 band. After fighting with it, I eventually got a flashing green light...but test goal alerts sent from my phone didn’t set my light off. Eventually, the flashing green light gave way to flashing orange. Turning the light off then back on gave me flashing green again, but again the test goal alerts did nothing, and again I got flashing orange again a short time later.

Budweiser sent out two other IMP cards for me to try, but they didn’t work either. Eventually, Budweiser sent me a brand new light (with a built-in IMP card) and the same thing is happening. I contacted my ISP and they changed one setting on my network (don’t know what it was) which didn’t fix the problem. They confirmed that my light’s MAC address showed up on my network, so it seems like it was connected. But, outside of the one change they made (which did nothing), they said there was nothing else they could do.

I finally took my light to a different network and it blinked up perfectly the first time and goal alerts from my phone set the light off. So, clearly my light works and it’s my network settings and/or hardware at home that is causing the problems. Everything else connects on my home wifi network without any problem: TV’s, iPhones, iPads, computers etc. I just cannot get my Bud Red Light to connect.

So, at this point, I’m guessing/hoping that there is some setting I can tweak on my router to get my BRL connected, but I have no idea where to start. Any ideas anyone?
Photo of FRANCIS MCRAE

FRANCIS MCRAE

  • 164 Points 100 badge 2x thumb

Posted 9 months ago

  • 2
Photo of Jeremy

Jeremy, Official Rep

  • 18,716 Points 10k badge 2x thumb
Hey Francis,
Sorry to hear about all the troubles your going through for your BRL.  Sounds like you've certainly done a lot to try and get this working.  I've never used one personally but my first guess could be that the signal through the router is being blocked, or disallowed.  I would suggest trying to setup port forwarding to your BRL to prevent any blockage, at least in that respect.  You'd have to find out from Budweiser which ports and protocol they use to transmit the signal on, then you would login to your router and add them.  There is a walk through on the Bell MTS support site to set this up if you need.
Hope this helps!
Photo of FRANCIS MCRAE

FRANCIS MCRAE

  • 164 Points 100 badge 2x thumb
I will definitely give this a go. Probably will try giving Budweiser support another call after work today to see what they say. I’ll keep you posted. Thanks so much for your speedy reply.
Photo of Clifford Lewis

Clifford Lewis, Champion

  • 27,218 Points 20k badge 2x thumb
Hi Francis,  

These are  from the  electricimp.com; Not sure if any of the tips in here will be of any help to you but thought I would let you know about them.<br><br>
https://forums.electricimp.com/t/budweiser-red-light/3756
https://forums.electricimp.com/t/budweiser-redlight-wont-connect/4353
(Edited)
Photo of FRANCIS MCRAE

FRANCIS MCRAE

  • 164 Points 100 badge 2x thumb
Yes, thank you for the links. I posted basically the same message on that forum as well! Thanks again!
Photo of FRANCIS MCRAE

FRANCIS MCRAE

  • 164 Points 100 badge 2x thumb
Talked to Budweiser support, and they believe my connectivity woes are related to a WiFi extender that we have running. Unfortunately, just turning off or unplugging the extender kills the WiFi signal, so I haven't been able to test this theory out as yet. Will kinda suck if I have to disconnect the extender every time a game is on and then reconnect it afterwards...
Photo of FRANCIS MCRAE

FRANCIS MCRAE

  • 164 Points 100 badge 2x thumb
Problem solved! Spoke with MTS support again this evening and explained that the problem could be related to the extender. He flipped a switch on my settings so that the main gateway box started to broadcast a WiFi signal under a different network name. Blinked up using the new network SSID and password, and the light works now.
Photo of Jeremy

Jeremy, Official Rep

  • 18,716 Points 10k badge 2x thumb
Glad to hear you got it working, having that second hop (the wifi extender) in the home can certainly complicate things sometimes.  Bypass that hop and your good to go.  
Photo of Lise T-b

Lise T-b

  • 60 Points
Thanks so much. I called MTS and read them your post. It worked!!!!!! So happy now!
Photo of Irene Simard

Irene Simard

  • 60 Points
I called them today and the guy I spoke to didn't have a clue what I was talking about. Another thing I noticed is the app on my android lists only three cities. It's frustrating I have reset and deleted app and started over numerous times. I can get to a green flashing light then it eventually stops but nothing. The light did not go off for tonight's game and it did not give me the 5 min warning
Photo of Clifford Lewis

Clifford Lewis, Champion

  • 27,218 Points 20k badge 2x thumb
Now the Jets have to start scoring goals for it to light up more