Address in directory

  • 1
  • Problem
  • Updated 2 years ago
  • Acknowledged
I specifically asked for my address not to be in the directory/on and I checked and all my information is there. This is a problem for me for privacy reasons. I made sure with the rep that only my name and phone number will be present. I also want to say that I was charged an install fee of $12 plus charged to have 900 numbers blocked. Those two were credited back but still shouldn't have been charged. With these 3 occurrences plus visual voicemail issue last week that will be 4 mistakes that happened on my account. How will MTS resolve these issues?

Photo of gordon1111

gordon1111, Champion

  • 12,804 Points 10k badge 2x thumb

Posted 2 years ago

  • 1
Photo of Megan

Megan, Official Rep

  • 3,326 Points 3k badge 2x thumb
Official Response
Hi Gordon, 

I apologize for the delay in my response, it seems my post yesterday did not show up. 

We definitely understand that these issues are very inconvenient to have to deal with, and we appreciate your time and patience with us having these errors fixed. I was actually the representative that placed the order for your phone service to be reconnected, and I can confirm that the order was set up with a Blank address, as previously advised on Twitter. We've contacted again to have them remove the address, however it is currently out of our hands to have it removed since we can't do that ourselves.

If you have any questions regarding your account, please feel free to email us at to assist you further.